Ubuntu 22.04 打开SSL 错误修复 – 迷途通

Ubuntu 22.04 打开SSL 错误修复

10月 21, 2022                      👁️ 254

Ubuntu 22.04 用户报告他们遇到 OpenSSL 错误 0A00018E。以下是修复错误的方法。

Ubuntu 22.04 打开SSL 错误 (问题)

Ubuntu和Xubuntu 22.04 迁移到 OpenSSL 3.0。这导致错误 (0A00018E:SSL routines::ca md too weak) 与 Wifi 和其他互联网连接。这是因为 OpenSSL 3.0 认为在旧 CA 证书上使用的 MD5 和 SHA1 哈希算法无效

开放SSL用于保护网络之间的通信。

如何修复Ubuntu 22.04中的OpenSSL错误

解决方案1:如果您使用的是Wi-Fi或VPN并且收到错误,那么立即的解决方案是续订密钥对以与OpenSSL 3兼容。这是因为在 Ubuntu 22.04 中默认使用的 OpenSSL 3 不接受 SHA1 算法。了解有关开放SSL 3.0的更多信息

解决方案 2: 安装打开SSL 3 。以下是有关如何在 Ubuntu 22.04 上安装 OpenSSL 3 的指南。

解决方案3:如果您遇到SSH问题,请确保您已选择性地启用了它,因为它在OpenSSH中默认处于禁用状态。

注意:使用 libssl1.1 的第三方软件包也需要升级到 libssl3。

发表回复

您的电子邮箱地址不会被公开。